16:54
ОбновитьСмайлыУправление мини-чатом
МИНИ-ЧАТ
Главная страница!

 



 
        
[SA-MP] Hosted Tab (128)
JasonGordon 21.10.2017 10:43
[MAP+FS] Тюрьма (15)
SubjectKalcor 09.10.2017 07:59
 





Рекомендуем:
Добавить IP: 95.172.59.51:7777





Последние Файлы GTA 4 Последние Файлы GTA-MP Реклама
Скрипт GTA 4 элементы Watch... 07.09.2014
Ferrari 360 Spider [EPM con... 13.12.2013
Porsche Cayenne Turbo 2012 ... 13.12.2013
Shelby Terlingua Mustang v1... 13.12.2013
Hamann Lamborghini Gallardo... 27.10.2013
Dgun (AvnanceRP,SampRP,Dimo... 19.03.2016
SAMP скрипт SX Events (MySQ... 03.03.2016
Карта ASL мэрия для SAMP се... 03.03.2016
AIM для SA-MP 0.3.7 22.02.2016
Скачать GTA SAMP 0.3.7 - Кл... 20.07.2015
Страница 1 из 11
Модератор форума: AXE, Weddew 
Форум SAMP о мультиплеерах для GTA. » SAMP скачивание и обсуждение » Вопросы и Проблемы » [Решено] Ошибка плагина после удаления плагина Mysql
[Решено] Ошибка плагина после удаления плагина Mysql
sehrgetДата: Суббота, 23.11.2013, 13:39 | Сообщение # 1
Постоялец
Группа: Продвинутые
Сообщений: 393
Награды: 2
Город: Украина\Черкассы
Замечания: 40%
Статус:
Добрый день. Сегодня я решил обновить версию Mysql плагина на сервере(ранее установленный плагин по неизвестным мне причинам не мог подсоединиться к серверу Mysql). Я удалил файл mysql.so в папке с плагинами и заменил его на более новый(скачал с буржуйского сайта о САМПе). При перезапуске мода мод не запустился(Mode: Unknown), в лог пошли вот такие чудесные ошибочки:
[cut noguest=Samplog]
Код
SA-MP Dedicated Server
----------------------
v0.3x, (C)2005-2013 SA-MP Team

[13:18:25]    
[13:18:25] Server Plugins
[13:18:25] --------------
[13:18:25]  Loading plugin: socket.so
[13:18:25]  Socket plugin v0.1b loaded.
[13:18:25]   Loaded.
[13:18:25]  Loading plugin: streamer.so
[13:18:25]    

*** Streamer Plugin v2.6.1 by Incognito loaded ***

[13:18:25]   Loaded.
[13:18:25]  Loaded 2 plugins.

[13:18:25]    
[13:18:25] Ban list
[13:18:25] --------
[13:18:25]  Loaded: samp.ban
[13:18:25]    
[13:18:25]    
[13:18:25] Filterscripts
[13:18:25] ---------------
[13:18:25]   Loading filterscript 'AntiCheat.amx'...
[13:18:25] ___________________________________________________
[13:18:25]     
[13:18:25]   Loaded 1 filterscripts.

[13:18:25] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_RegisterInterface" found (script might need to be recompiled with the latest include file)
[13:18:25] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_AddPlayer" found (script might need to be recompiled with the latest include file)
[13:18:25] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_RemovePlayer" found (script might need to be recompiled with the latest include file)
[13:18:25] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_VerifyPickup" found (script might need to be recompiled with the latest include file)
[13:18:25] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_VerifyCheckpoint" found (script might need to be recompiled with the latest include file)
[13:18:25] *** Streamer Plugin: Warning: Include file version (unknown version) does not match plugin version (0x26105) (script might need to be recompiled with the latest include file)
[13:18:25] Script[gamemodes/PontGame.amx]: Run time error 19: "File or function is not found"
[13:18:25] Number of vehicle models: 0
[/cut]



Сообщение отредактировал sehrget - Суббота, 23.11.2013, 16:10
WeddewДата: Суббота, 23.11.2013, 15:04 | Сообщение # 2
Группа: Ангел Хранитель
Сообщений: 1242
Награды: 19
Город: Казань
Репутация: 1740
Замечания: 0%
Статус:
Плагин != скрипт
streamer.inc(141) : error 021: symbol already defined: "IsValidDynamicObject"
Такие ошибки выходят, если к исходному коду мода подключен заголовочный файл стримера.
Посмотрите, нет ли где еще.
[pwn]#include <streamer>[/pwn]

Нельзя вот так просто взять и заменить плагин mysql. Необходимо переписать системы связанные с mysql под новую версию плагина.




www.weddew-shop.ru
AlcoholikДата: Суббота, 23.11.2013, 15:06 | Сообщение # 3
Группа: Администратор
Сообщений: 8287
Награды: 111
Город: Санкт-Петербург
Репутация: 5945
Статус:
Цитата Weddew ()
Необходимо переписать системы связанные с mysql под новую версию плагина.

А что, стример разве как-то связан с mysql`ом?



if(isset($beer)&&isset($girl)) { drink($beer);fuck($girl); }else die();
Мониторинг sa:mp серверов


Приватно никого не консультирую, моды также не пишу, ни так, ни за деньги.
Моя ICQ 675715, пишу только с неё. Все остальные Роачи фейки, ничего я не продаю и продавать не буду, вас разводят.
sehrgetДата: Суббота, 23.11.2013, 16:14 | Сообщение # 4
Постоялец
Группа: Продвинутые
Сообщений: 393
Награды: 2
Город: Украина\Черкассы
Замечания: 40%
Статус:
Цитата Weddew ()
Посмотрите, нет ли где еще.
#include <streamer>

Благодарю, помогло(видимо указан в других инклудах).

Добавлено (23.11.2013, 16:14)
---------------------------------------------
Но ошибки в логе остались хотя мод загружается

Код
SA-MP Dedicated Server
----------------------
v0.3x, (C)2005-2013 SA-MP Team

[15:27:06]  
[15:27:06] Server Plugins
[15:27:06] --------------
[15:27:06]  Loading plugin: socket.so
[15:27:06]  Socket plugin v0.1b loaded.
[15:27:06]   Loaded.
[15:27:06]  Loading plugin: streamer.so
[15:27:06]  

*** Streamer Plugin v2.6.1 by Incognito loaded ***

[15:27:06]   Loaded.
[15:27:06]  Loaded 2 plugins.

[15:27:06]  
[15:27:06] Ban list
[15:27:06] --------
[15:27:06]  Loaded: samp.ban
[15:27:06]  
[15:27:06]  
[15:27:06] Filterscripts
[15:27:06] ---------------
[15:27:06]   Loading filterscript 'AntiCheat.amx'...
[15:27:06]   FS AntiCheat v3.055 [12.09.2013] By: Mark_Edisson
[15:27:06] ___________________________________________________
[15:27:06]   
[15:27:06]   Loaded 1 filterscripts.

[15:27:06] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_RegisterInterface" found (script might need to be recompiled with the latest include file)
[15:27:06] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_AddPlayer" found (script might need to be recompiled with the latest include file)
[15:27:06] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_RemovePlayer" found (script might need to be recompiled with the latest include file)
[15:27:06] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_VerifyPickup" found (script might need to be recompiled with the latest include file)
[15:27:06] *** Streamer Plugin: Warning: Obsolete or invalid native "Streamer_VerifyCheckpoint" found (script might need to be recompiled with the latest include file)
[15:27:06] *** Streamer Plugin: Warning: Include file version (unknown version) does not match plugin version (0x26105) (script might need to be recompiled with the latest include file)
[15:27:06] Система гангзон успешно загружена!
[15:27:06] Машина: [0] | Модель: [301] | Стоимость: [$1215752192] | Владелец: [The_State]
[15:27:06] Машина: [1] | Модель: [301] | Стоимость: [$1215752192] | Влад
елец: [The_State]

WeddewДата: Суббота, 23.11.2013, 21:33 | Сообщение # 5
Группа: Ангел Хранитель
Сообщений: 1242
Награды: 19
Город: Казань
Репутация: 1740
Замечания: 0%
Статус:
Цитата sehrget ()
Но ошибки в логе остались хотя мод загружается

Обновите плагин и инклуд стримера и перекомпилируйте мод. Скачать можно здесь http://forum.sa-mp.com/showthread.php?t=102865

Добавлено (23.11.2013, 21:33)
---------------------------------------------

Цитата RoACh ()
А что, стример разве как-то связан с mysql`ом?

Цитата sehrget ()
Сегодня я решил обновить версию Mysql плагина на сервере(ранее установленный плагин по неизвестным мне причинам не мог подсоединиться к серверу Mysql)

Цитата Weddew ()
Нельзя вот так просто взять и заменить плагин mysql. Необходимо переписать системы связанные с mysql под новую версию плагина.




www.weddew-shop.ru
Форум SAMP о мультиплеерах для GTA. » SAMP скачивание и обсуждение » Вопросы и Проблемы » [Решено] Ошибка плагина после удаления плагина Mysql
Страница 1 из 11
Поиск:





 


 


 
Хостинг от uCoz SAMP-RUS.COM